I’m having trouble downloading it – which software do I need?

Check if you’ve got the latest software installed on your phone, and then try again. You must have either iOS 10 or later, or Android 5.1 or later.